你的位置:首页 > 数据库

[数据库]postgresql无法安装pldbgapi的问题

要对函数进行调试需要安装插件pldbgapi,当初在windows上面的postgresql实例中执行了一下语句就安装上了:

create extension pldbgapi;

 

但是在linux中执行该语句时提示没有这个文件,上网查了好几个资料,使用德哥的方法。不过在实际操作中还是有出入,这里做一下记录,分享给大家:

1.从git上下载对应的模块:

git clone git://git.postgresql.org/git/pldebugger.git

 

2.拷贝到lib目录下,德哥的方法是将整个文件夹拷贝到contrib目录下,在make的时候会报错,经过分析,原来make用到postgresql的make文件,路径有问题,需要将pldebugger/目录下的文件拷贝到contrib/目录下

cp pldebugger/* $pgsrc/contrib

--pgsrc是跟postgresql源码的src目录。

 

3.进入contrib进行安装

cd $pgsrc/contrib

make

make install

 

4.执行一下源码中/src/contrib目录下的pldbgapi--1.0.sql文件,文件名可能不一样,pldbgapi开头的sql文件即可:

psql -f pldbgapi--1.0.sql mydb

或者

psql

create extension pldbgaip;

 

就这样安装完成,可以进行调试了。

 

下面是参考德哥的链接:http://blog.163.com/digoal@126/blog/static/16387704020125511841144/